MTU.Community


Go Back   MTU.Community > Hoster Software > Hoster Help

Hoster Help Post Hoster questions, tips and suggestions here.

Reply
 
Thread Tools Display Modes
  #1  
Old May 16th, 2020, 11:45 PM
Cpucino Cpucino is offline
Registered User
 
Join Date: Apr 2007
Location: Racine, WI
Posts: 7
dual audio devices

I run my show using a Windows 10 64 bit computer with two audio devices: an on-board HD audio device and an ASUS Xonar Essence ST PCIe audio card. My goal is to have Hoster play karaoke and video files using the HD audio device while a second program uses the Xonar device to play FLAC audio files. This allows each to connect to their own stereo channel on the mixer and in turn makes it way easier to run the show.

I set Hoster to use the HD device as the primary and the Xonar as the secondary. The Windows default audio device is the HD device. Works like a charm for karaoke files (MP3G, KMH, etc.). But when playing a video file (MP4, AVI, etc.), the sound is routed through the Xonar card. Checked for any settings that might affect this in my codecs but found nothing obvious. Any help with this issue would be greatly appreciated.

Thanks in advance.
Reply With Quote
  #2  
Old May 17th, 2020, 09:20 AM
Roy Dennis's Avatar
Roy Dennis Roy Dennis is offline
Super Moderator
 
Join Date: Mar 2004
Location: Kent, England
Posts: 6,299
Re: dual audio devices

Normally provided you set the default device in windows sound settings to the same as your primary sound card in Hoster anything played from the Hoster playlist plays through that.
Sometimes trying to change the audio settings from within Hoster audio does not always work properly.
Best to close Hoster and make these changes first.

Double check these settings before starting Hoster.
1) right click on speaker icon on taskbar and select “open sound settings”
2) Where it reads “Choose your output device” make sure that shows as your HD audio device the same one you want to use as Primary in Hoster.
3)On the right hand side of the dialog select “Sound control Panel”
4) You should now be in the old sound settings dialog, check that that is showing your HD audio as the default device, if not select it and set as default.
5)Now select your Asus essence card by highlighting it,. Now select properties at the bottom for that dialog then the advanced tab at the top, there are two tick boxes at the bottom under exclusive mode untick both boxes if they are ticked and press OK.
Now while your in this dialog if there are any other sound devices showing that you don’t use disable them. For instance HDMI output unless that is the one you refer to as the HD device. Then OK again to exit the sound settings.

Now start Hoster and set the Primary and secondary cards again in Hosters sound settings press apply and close.

Now see if your videos play as normal.
__________________
Roy.
Test Laptop: Windows 10 Home Premium 64bit. Acer Aspire 5738G Intel core 2 Duo T6600 ATI Graphics 500Mb dedicated. 4Gb Memory 500 Gb SSD Drive. K-lite Mega version 1205
Show Backup: Windows 10 Acer Aspire Touch Screen V15, Intel core i5, Iris Graphics 6100 up to 8277mb dynamic video, 16Gb memory, 1 TB hybrid HDD. K-lite Mega pac.
Show Computer: Windows 10, Dell Inspiron 15 7000, CPU I7-855OU, Ram 8GB, Graphics UHD620 + Nvidea GeForce 940MX, Hard Drive SSD 256GB + 1GB internal.
Reply With Quote
Reply

Tags
audio, device, wrong


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 07:27 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2009 - 2021, Jelsoft Enterprises Ltd.
The contents of this forum are copyrighted by Micro Technology Unlimited, 2000-2008. Use of any material from these Forums is prohibited without written agreement from MTU.